Back to overview
Resolved
Email delivery issues
Jul 20, 2026 at 6:26am UTC
Affected services
Outgoing e-mails
Resolved
Jul 20, 2026 at 10:52am UTC
The problem has been resolved. Sorry for any inconvenience!
Affected services
Created
Jul 20, 2026 at 6:26am UTC
Our email provider is currently experiencing issues, which may in some not being delivered.
This affects both emails sent via our API and our own system emails, including 2FA messages.
We apologize for any inconvenience this may cause. We are monitoring the situation closely and will provide updates as soon as more information becomes available.
Affected services