Back to overview
Downtime

Email delivery issues

Feb 22 at 01:37pm CET
Affected services
Outgoing e-mails

Resolved
Feb 22 at 02:21pm CET

The issue affecting email delivery has been resolved, and emails are now being sent normally from our platform. If the situation changes, we will provide a new status update.

We apologize for any inconvenience this may have caused.

Created
Feb 22 at 01:37pm CET

Our email provider is currently experiencing operational issues, which means we are temporarily unable to send emails from our platform.

This affects both emails sent via our API and our own system emails, including 2FA messages.

We apologize for any inconvenience this may cause. We are monitoring the situation closely and will provide updates as soon as more information becomes available.