Back to overview
Degraded

Incoming messages from Telia/Norlys unavailable

Dec 9, 2025 at 4:58pm UTC
Affected services
Denmark (+45) - incoming/MO

Resolved
Dec 9, 2025 at 7:58pm UTC

We are receiving messages again from Telia/Norlys.
We'll keep monitoring for any issues.

Updated
Dec 9, 2025 at 7:35pm UTC

Telia/Norlys are experiencing are power failure at one of their network sites, which is the cause of this issue.

Created
Dec 9, 2025 at 4:58pm UTC

Some of our danish virtual numbers, that are hosted at Telia/Norlys are currently unavailable.