Back to overview
Downtime
Emails are sent multiple times
Mar 04 at 01:37pm CET
Affected services
Outgoing e-mails
Resolved
Mar 04 at 02:05pm CET
We have now identified the issue in our email setup, and it has been resolved. Emails are being sent again. We apologize for any inconvenience this may have caused.
Affected services
Outgoing e-mails
Created
Mar 04 at 01:37pm CET
We experience that emails sent from our systems are sent multiple times. We are working on a solution. We have currently disabled all mail sending to prevent flooding our customers inboxes.
Affected services
Outgoing e-mails