Back to overview
Resolved

Issues Delivering Emails to Outlook Addresses

Sep 4, 2026 at 8:25am UTC
Affected services
inMobile online platform
Outgoing e-mails

Resolved
Sep 4, 2026 at 12:50pm UTC

The issue affecting email delivery to and from Exchange Online appears to have been resolved.

We are closing this incident and will continue to monitor the situation.

Updated
Sep 4, 2026 at 11:33am UTC

Microsoft has acknowledged the issue affecting email delivery to and from Exchange Online and is currently investigating the cause.

As the issue is with Microsoft’s services, there is currently no action we can take on our side. We are monitoring the situation and will provide further updates as they become available.

Created
Sep 4, 2026 at 8:25am UTC

We are currently experiencing issues with outbound emails to Outlook email addresses.

We are aware of the issue and are actively monitoring the situation. At this time, the issue appears to be outside of our systems, and there are no actions we can take on our end to resolve it.

We will continue to monitor the situation and provide updates as needed.